【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法

  • 【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法已关闭评论
  • 4,543 views
  • A+
所属分类:日常折腾

如果看过我前一篇文章的小伙伴应该都知道(详情参考这篇文章:闲鱼上买了个二手iphone 4s,第一次用苹果手机居然是它!)我已经把这个iphone 4s来来回回折腾了好多遍了。最开始拿到的时候,上面有一个微信,我登录提示版本过低,但是在爱思助手里面安装微信却提示系统版本低。原始系统是613版本,也就是大家口中所说的最流畅、最省电版本。

我当时直接就升级成了9.3.5版本,微信倒是可以安装7.0.2旧版本,但问题来了,它卡啊。微信里面点个“通讯录”,半天没反应,整个手机的流畅度也下降了。果然不行啊。本来我都放弃折腾了,这毕竟是我买个我妈当老人机用的,能打打电话就ok了。

但现在又手痒了,又想来把微信安装上。如果一个4s不安装微信,那和咸鱼有什么区别?据说淘宝上面有卖,安装服务的。价格在10元到20元不等。我又舍不得花这个钱。那没办法,只能花时间来折腾呗。

我先说一下,我从开始折腾到最终完成这个微信正常登录。花了接近5个小时。刷机至少三次,其实刷错版本一次,实际只需要刷两次即可。越狱也是好几次。

先给大家看看最终成果图:
【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法图片 No.1

【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法图片 No.2

好了,现在讲解过程:
先说两个前提。你可以准备两部苹果手机,都是越狱状态。如果没有话,一部iphone 4s也可以,但要刷机。原教程说的是可以安装一个双系统。但是存储要求比较大,我的8G的,容量不够。所以,我选择的是刷机。

第一大步:导出微信的wx.dat文件

1、先把4s刷机到9.3.5版本。刷机使用爱思助手。然后要越狱,越狱是一定的,不然根本找不到文件。(我在这里耽误很多时间)里面搜索微信,会找到一个旧版本,7.0.2。

【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法图片 No.3
2、安装上微信之后,登录你的微信账号。这个版本是可以正常登录的,完全没问题。
3、电脑上安装iTools 4,连接上手机。导出微信数据文件wx.dat,路径位置:/var/mobile/Containers/Data/Application/微信(这里是指一长串数字)/Library/WechatPrivate/wx.dat ,(wx.dat这个文件就是我们需要的)(可以用iTools搜索关键词wx.dat,定位文件位置。)
注意:这里我搜索到了三个,只有一个路径是符合要求的。直接导出它,其他两个是不是也能,我没验证。

综上,4s刷机系统版本为9.3.5的目的,就是为了将wx.dat文件导出来。

如果你有其他苹果手机,越狱之后,可以直接导出这个文件,步骤如上操作。

第二大步:替换wx.dat文件,修改“info.plist”文件

1、刷机回来613版本。越狱掉。爱思助手无脑操作即可。
【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法图片 No.4

2.安装微信6.2版本。怎么安装。用91助手。爱思助手连接上4s,在程序里,导入安装91的旧版本。这里提供下载,链接:https://pan.baidu.com/s/1XAyJqrfwvmq4_nIducVv7 提取码:thcc

【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法图片 No.5

这在这里遇到一些困难,导入时提示:手机未安装appsync越狱补丁。好了,关于这个解决方法参考这篇文章:越狱后一定要安装的补丁:appsync和afc2

安装好91助手之后,在里面直接搜索:微信,找到的版本,就是6.2版本。

3、将6.2版本的微信打开一次(打开是必须的过程,不然后续wx.dat无法搜索到)。

4、定位到wx.dat文件。iTools 4进行文件查找,路径:/var/mobile/Applications/微信(这里是指一长串数字)/Library/WechatPrivate/wx.dat,将wx.dat文件删掉,然后将上一大步导出来的wx.dat导入进来。

5、进入微信主程序路径/var/mobile/Applications/微信/WeChat.app,
找到“info.plist”,搜索结果会出现三个 info.plist 的文件,你对比上面的路径操作对应文件(改一个就完全ok),打开它,搜索“6.2”,把它下面键值改成 “6.5.0.19”,有三处要修改。(要提现功能就改成 6.5.5.32 ,但是改成 6.5.5 不一定能登陆!需要提现时可以再改)改完之后,一定要保存。

【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法图片 No.6 【2019.7.23更新】苹果iphone 4s 613系统版本【提示微信版本过低】(微信无法使用)的解决方法图片 No.7

6、将微信的后台杀掉,重新打开。登录你的微信账号(这个账号是你第一大步导出wx.dat的那个微信账号,不同的账号可能会无法登录,这点小Y没有求证过,大家自行尝试),这就可以正常地登录了,不会再提示版本过低了。

avatar